`

ACM题:ASCII码排序(2000)

    博客分类:
  • ACM
阅读更多
ASCII码排序
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10683    Accepted Submission(s): 4586


Problem Description
输入三个字符后,按各字符的ASCII码从小到大的顺序输出这三个字符。


Input
输入数据有多组,每组占一行,有三个字符组成,之间无空格。


Output
对于每组输入数据,输出一行,字符中间用一个空格分开。


Sample Input
qwe
asd
zxc


Sample Output
e q w
a d s
c x z

simple c code:
#include <stdio.h>
#include<string.h>
int main()
{
char s[3],a,b,c,temp;
int i,j,index,flag;
while(scanf("%s",s)!=EOF)
{
a=s[0];b=s[1];c=s[2];
if(a>b)
{
temp=a;
a=b;
b=temp;
}
if(a>c)
{
printf("%c %c %c\n",c,a,b);
}
else if(b<c)
{
printf("%c %c %c\n",a,b,c);
}
else
{
printf("%c %c %c\n",a,c,b);
}

}
return 0;
}
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics